Internet Exchange Loss of Power
Incident Report for
Wasatch Broadband Network Status
Resolved
Power has been restored
Posted
Jan
27
,
2026
-
17:40
MST
Investigating
Databank SLC1 will lose power this evening from 6PM until 6AM tomorrow morning. Backup power and backup routers will continue to pass internet traffic but your Billing and some monitoring will be affected.
Posted
Jan
26
,
2026
-
17:21
MST
×
Subscribe to Incident
Subscribe to updates for
Internet Exchange Loss of Power
via . You'll receive .