known fiber cut has us running on a backup link. you may experience brief outages over the next few hours
Incident Report for Wasatch Broadband Network Status
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 08:33 MST
Update
The fiber has been fixed, and service restored to full capacity.
Posted Jan 14, 2025 - 08:33 MST
Update
We are continuing to work on a fix for this issue.
Posted Jan 14, 2025 - 08:32 MST
Update
We are continuing to work on a fix for this issue.
Posted Jan 13, 2025 - 16:27 MST
Identified
We are currently waiting on work to be done to get the fiber operational
Posted Jan 13, 2025 - 16:16 MST
This incident affected: Saratoga Springs (South of Maverick, Hillcrest Condos, Daybreak Condos) and Eagle Mountain (North of Pony Express, South of Pony Express, Willow Springs Condos, Rock Creek Condos).