Phone and text outage due to AWS issues this morning

Incident Report for Wasatch Broadband Network Status

Resolved

This incident has been resolved.
Posted Oct 22, 2025 - 15:10 MDT

Monitoring

Phone calls and text messages to our office are not routing properly. If you need to communicate with us, please use support@wasatchbroadband.net and we will respond as quickly as possible. This outage is due to a known issue with Amazon Web Services. Our phone system is hosted through one of their affiliates, and as a result we are unable to receive calls or text messages.
Posted Oct 20, 2025 - 12:01 MDT