Power outage in Pleasant Grove/Lindon/Orem
Incident Report for
Wasatch Broadband Network Status
Resolved
We have power to the site and are continuing to work on a permanent solution
Posted
Oct
15
,
2025
-
12:42
MDT
Identified
The issue has been identified and a fix is being implemented.
Posted
Oct
14
,
2025
-
12:30
MDT
This incident affected: Orem | Lindon | PG (North Orem/Lindon).
×
Subscribe to Incident
Subscribe to updates for
Power outage in Pleasant Grove/Lindon/Orem
via . You'll receive .